Installation

Tensorflow_hub installieren

Die Bibliothek tensorflow_hub kann neben TensorFlow 1 und TensorFlow 2 installiert werden. Wir empfehlen neuen Benutzern, sofort mit TensorFlow 2 zu beginnen und aktuelle Benutzer darauf zu aktualisieren.

Verwendung mit TensorFlow 2

Verwenden Sie pip , um TensorFlow 2 wie gewohnt zu installieren . (Weitere Anweisungen zur GPU-Unterstützung finden Sie dort.) Installieren Sie anschließend eine aktuelle Version des tensorflow-hub (muss 0.5.0 oder neuer sein).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

Die TF1-API von TensorFlow Hub arbeitet mit dem v1-Kompatibilitätsmodus von TensorFlow 2.

Legacy-Verwendung mit TensorFlow 1

TensorFlow 1.15 ist die einzige Version von TensorFlow 1.x, die noch von der Bibliothek tensorflow_hub unterstützt wird (ab Version 0.11.0). TensorFlow 1.15 verwendet standardmäßig TF1-kompatibles Verhalten, enthält jedoch viele TF2-Funktionen unter der Haube, um die Verwendung der TF2-APIs von TensorFlow Hub zu ermöglichen.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Verwendung von Pre-Release-Versionen

Die Pip-Pakete tf-nightly und tf-hub-nightly werden ohne Release-Test automatisch aus dem Quellcode auf github erstellt. Auf diese Weise können Entwickler die neuesten Code ausprobieren, ohne die Sourcen .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Nächste Schritte