Ayuda a proteger la Gran Barrera de Coral con TensorFlow en Kaggle Únete Challenge

Instalación

Instalando tensorflow_hub

El tensorflow_hub biblioteca puede ser instalado junto TensorFlow 1 y TensorFlow 2. Se recomienda que los nuevos usuarios comienzan con TensorFlow 2 de inmediato, y los usuarios actuales pasaron a él.

Usar con TensorFlow 2

El uso de pepita a instalar TensorFlow 2 como de costumbre. (Véase allí para obtener instrucciones adicionales sobre el apoyo de la GPU.) A continuación, instalar una versión actual de tensorflow-hub al lado de él (debe ser 0.5.0 o posterior).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

La API de estilo TF1 de TensorFlow Hub funciona con el modo de compatibilidad v1 de TensorFlow 2.

Uso heredado con TensorFlow 1

TensorFlow 1,15 es la única versión de TensorFlow 1.x todavía el apoyo de la tensorflow_hub biblioteca (como de liberación 0.11.0). TensorFlow 1.15 tiene un comportamiento compatible con TF1 de forma predeterminada, pero contiene muchas funciones de TF2 bajo el capó para permitir cierto uso de las API de estilo TF2 de TensorFlow Hub.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Uso de versiones preliminares

Los paquetes de pepita tf-nightly y tf-hub-nightly se construyen de forma automática desde el código fuente en GitHub, sin pruebas de liberación. Esto permite a los desarrolladores probar el último código sin compilar desde las fuentes .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Próximos pasos