Google is committed to advancing racial equity for Black communities. See how.

Instalar o TensorFlow para Java

O TensorFlow fornece uma API Java, especialmente útil para carregar modelos criados com Python e executá-los em um aplicativo Java.

Plataformas compatíveis

O TensorFlow para Java é compatível com os seguintes sistemas:

  • Ubuntu 16.04 ou superior; 64 bits, x86
  • macOS 10.12.6 (Sierra) ou superior
  • Windows 7 ou superior; 64 bits, x86

Para instalar o TensorFlow no Android, consulte o suporte do TensorFlow no Android e a demonstração da câmera Android do TensorFlow.

TensorFlow com Apache Maven

Para usar o TensorFlow com o Apache Maven, adicione a dependência ao arquivo pom.xml do projeto:

<dependency>
  <groupId>org.tensorflow</groupId>
  <artifactId>tensorflow</artifactId>
  <version>1.14.0</version>
</dependency>

Suporte a GPUs

Se o sistema tiver suporte a GPUs, adicione as seguintes dependências do TensorFlow ao arquivo pom.xml do projeto:

<dependency>
  <groupId>org.tensorflow</groupId>
  <artifactId>libtensorflow</artifactId>
  <version>1.14.0</version>
</dependency>
<dependency>
  <groupId>org.tensorflow</groupId>
  <artifactId>libtensorflow_jni_gpu</artifactId>
  <version>1.14.0</version>
</dependency>

Programa de exemplo

Este exemplo mostra como criar um projeto do Apache Maven com o TensorFlow. Primeiro, adicione a dependência do TensorFlow ao arquivo pom.xml do projeto:

<project>
  <modelVersion>4.0.0</modelVersion>
  <groupId>org.myorg</groupId>
  <artifactId>hellotensorflow</artifactId>
  <version>1.0-SNAPSHOT</version>
  <properties>
    <exec.mainClass>HelloTensorFlow</exec.mainClass>
    <!-- The sample code requires at least JDK 1.7. -->
    <!-- The maven compiler plugin defaults to a lower version -->
    <maven.compiler.source>1.7</maven.compiler.source>
    <maven.compiler.target>1.7</maven.compiler.target>
  </properties>
  <dependencies>
    <dependency>
      <groupId>org.tensorflow</groupId>
      <artifactId>tensorflow</artifactId>
      <version>1.14.0</version>
    </dependency>
  </dependencies>
</project>

Crie o arquivo de origem (src/main/java/HelloTensorFlow.java):

import org.tensorflow.Graph;
import org.tensorflow.Session;
import org.tensorflow.Tensor;
import org.tensorflow.TensorFlow;

public class HelloTensorFlow {
  public static void main(String[] args) throws Exception {
    try (Graph g = new Graph()) {
      final String value = "Hello from " + TensorFlow.version();

      // Construct the computation graph with a single operation, a constant
      // named "MyConst" with a value "value".
      try (Tensor t = Tensor.create(value.getBytes("UTF-8"))) {
        // The Java API doesn't yet include convenience functions for adding operations.
        g.opBuilder("Const", "MyConst").setAttr("dtype", t.dataType()).setAttr("value", t).build();
      }

      // Execute the "MyConst" operation in a Session.
      try (Session s = new Session(g);
          // Generally, there may be multiple output tensors,
          // all of them must be closed to prevent resource leaks.
          Tensor output = s.runner().fetch("MyConst").run().get(0)) {
        System.out.println(new String(output.bytesValue(), "UTF-8"));
      }
    }
  }
}

Compile e execute:

mvn -q compile exec:java  # Use -q to hide logging

O comando gera: Hello from version

TensorFlow com JDK

O TensorFlow pode ser usado com o JDK por meio da Java Native Interface (JNI).

Fazer o download

  1. Faça o download do arquivo JAR do TensorFlow (JAR): libensorflow.jar
  2. Faça o download e extraia o arquivo da Java Native Interface (JNI) para dar suporte ao seu processador e sistema operacional:
Versão da JNIURL
Linux
Somente CPU Linux https://storage.googleapis.com/tensorflow/libtensorflow/libtensorflow_jni-cpu-linux-x86_64-1.14.0.tar.gz
Suporte a GPUs do Linux https://storage.googleapis.com/tensorflow/libtensorflow/libtensorflow_jni-gpu-linux-x86_64-1.14.0.tar.gz
macOS
Somente CPU do macOS https://storage.googleapis.com/tensorflow/libtensorflow/libtensorflow_jni-cpu-darwin-x86_64-1.14.0.tar.gz
Windows
Somente CPU do Windows https://storage.googleapis.com/tensorflow/libtensorflow/libtensorflow_jni-cpu-windows-x86_64-1.14.0.zip
Suporte a GPUs do Windows https://storage.googleapis.com/tensorflow/libtensorflow/libtensorflow_jni-gpu-windows-x86_64-1.14.0.zip

Compilar

Usando o arquivo HelloTensorFlow.java do exemplo anterior, compile um programa que usa o TensorFlow. Verifique se o libtensorflow.jar está acessível para seu classpath:

javac -cp libtensorflow-1.14.0.jar HelloTensorFlow.java

Executar

Para executar um programa Java do TensorFlow, a JVM precisa acessar libtensorflow.jar e a biblioteca JNI extraída.

Linux / macOS

java -cp libtensorflow-1.14.0.jar:. -Djava.library.path=./jni HelloTensorFlow

Windows

java -cp libtensorflow-1.14.0.jar;. -Djava.library.path=jni HelloTensorFlow

O comando gera: Hello from version

Criar da origem

O TensorFlow é de código aberto. Leia as instruções para criar bibliotecas nativas e Java do TensorFlow a partir do código-fonte.