Python ile Linux tabanlı cihazlar için hızlı başlangıç

Koleksiyonlar ile düzeninizi koruyun İçeriği tercihlerinize göre kaydedin ve kategorilere ayırın.

TensorFlow Lite'ı Python ile kullanmak, Raspberry Pi ve Edge TPU'lu Coral cihazları gibi Linux tabanlı gömülü cihazlar için harikadır.

Bu sayfa, TensorFlow Lite modellerini Python ile birkaç dakika içinde nasıl çalıştırmaya başlayabileceğinizi gösterir. Tek ihtiyacınız olan, TensorFlow Lite'a dönüştürülmüş bir TensorFlow modelidir. (Henüz dönüştürülmüş bir modeliniz yoksa, aşağıda bağlantısı verilen örnekle sağlanan modeli kullanarak deneme yapabilirsiniz.)

TensorFlow Lite çalışma zamanı paketi hakkında

Python ile TensorFlow Lite modellerini hızlı bir şekilde yürütmeye başlamak için tüm TensorFlow paketleri yerine yalnızca TensorFlow Lite yorumlayıcısını yükleyebilirsiniz. Bu basitleştirilmiş Python paketini tflite_runtime .

tflite_runtime paketi, tam tensorflow paketinin boyutunun çok küçük bir kısmıdır ve TensorFlow Lite ile çıkarımları çalıştırmak için gereken minimum minimum kodu, özellikle de Interpreter Python sınıfını içerir. Bu küçük paket, tek yapmak istediğiniz .tflite modellerini çalıştırmak ve büyük TensorFlow kitaplığı ile disk alanını boşa harcamaktan kaçınmak olduğunda idealdir.

Python için TensorFlow Lite'ı yükleyin

Linux'a pip ile kurabilirsiniz:

python3 -m pip install tflite-runtime

Desteklenen platformlar

tflite-runtime Python tekerlekleri önceden oluşturulmuş ve şu platformlar için sağlanmıştır:

  • Linux armv7l (örneğin Raspberry Pi OS 32-bit çalıştıran Raspberry Pi 2, 3, 4 ve Zero 2)
  • Linux aarch64 (örneğin Debian ARM64 çalıştıran Raspberry Pi 3, 4)
  • Linux x86_64

TensorFlow Lite modellerini diğer platformlarda çalıştırmak istiyorsanız, tam TensorFlow paketini kullanmalı veya tflite-runtime paketini source 'den oluşturmalısınız .

Coral Edge TPU ile TensorFlow kullanıyorsanız, bunun yerine uygun Coral kurulum belgelerini izlemelisiniz.

tflite_runtime kullanarak bir çıkarım çalıştırın

Interpreter tensorflow modülünden içe aktarmak yerine, şimdi onu tflite_runtime içe aktarmanız gerekir.

Örneğin yukarıdaki paketi kurduktan sonra label_image.py dosyasını kopyalayıp çalıştırın. Yüklü tensorflow kitaplığınız olmadığı için (muhtemelen) başarısız olacaktır. Düzeltmek için dosyanın şu satırını düzenleyin:

import tensorflow as tf

Yani bunun yerine okur:

import tflite_runtime.interpreter as tflite

Ve sonra bu satırı değiştirin:

interpreter = tf.lite.Interpreter(model_path=args.model_file)

Yani okur:

interpreter = tflite.Interpreter(model_path=args.model_file)

Şimdi label_image.py tekrar çalıştırın. Bu kadar! Artık TensorFlow Lite modellerini yürütüyorsunuz.

Daha fazla bilgi edin

,

TensorFlow Lite'ı Python ile kullanmak, Raspberry Pi ve Edge TPU'lu Coral cihazları gibi Linux tabanlı gömülü cihazlar için harikadır.

Bu sayfa, TensorFlow Lite modellerini Python ile birkaç dakika içinde nasıl çalıştırmaya başlayabileceğinizi gösterir. Tek ihtiyacınız olan, TensorFlow Lite'a dönüştürülmüş bir TensorFlow modelidir. (Henüz dönüştürülmüş bir modeliniz yoksa, aşağıda bağlantısı verilen örnekle sağlanan modeli kullanarak deneme yapabilirsiniz.)

TensorFlow Lite çalışma zamanı paketi hakkında

Python ile TensorFlow Lite modellerini hızlı bir şekilde yürütmeye başlamak için tüm TensorFlow paketleri yerine yalnızca TensorFlow Lite yorumlayıcısını yükleyebilirsiniz. Bu basitleştirilmiş Python paketini tflite_runtime .

tflite_runtime paketi, tam tensorflow paketinin boyutunun çok küçük bir kısmıdır ve TensorFlow Lite ile çıkarımları çalıştırmak için gereken minimum minimum kodu, özellikle de Interpreter Python sınıfını içerir. Bu küçük paket, tek yapmak istediğiniz .tflite modellerini çalıştırmak ve büyük TensorFlow kitaplığı ile disk alanını boşa harcamaktan kaçınmak olduğunda idealdir.

Python için TensorFlow Lite'ı yükleyin

Linux'a pip ile kurabilirsiniz:

python3 -m pip install tflite-runtime

Desteklenen platformlar

tflite-runtime Python tekerlekleri önceden oluşturulmuş ve şu platformlar için sağlanmıştır:

  • Linux armv7l (örneğin Raspberry Pi OS 32-bit çalıştıran Raspberry Pi 2, 3, 4 ve Zero 2)
  • Linux aarch64 (örneğin Debian ARM64 çalıştıran Raspberry Pi 3, 4)
  • Linux x86_64

TensorFlow Lite modellerini diğer platformlarda çalıştırmak istiyorsanız, tam TensorFlow paketini kullanmalı veya tflite-runtime paketini source 'den oluşturmalısınız .

Coral Edge TPU ile TensorFlow kullanıyorsanız, bunun yerine uygun Coral kurulum belgelerini izlemelisiniz.

tflite_runtime kullanarak bir çıkarım çalıştırın

Interpreter tensorflow modülünden içe aktarmak yerine, şimdi onu tflite_runtime içe aktarmanız gerekir.

Örneğin yukarıdaki paketi kurduktan sonra label_image.py dosyasını kopyalayıp çalıştırın. Yüklü tensorflow kitaplığınız olmadığı için (muhtemelen) başarısız olacaktır. Düzeltmek için dosyanın şu satırını düzenleyin:

import tensorflow as tf

Yani bunun yerine okur:

import tflite_runtime.interpreter as tflite

Ve sonra bu satırı değiştirin:

interpreter = tf.lite.Interpreter(model_path=args.model_file)

Yani okur:

interpreter = tflite.Interpreter(model_path=args.model_file)

Şimdi label_image.py tekrar çalıştırın. Bu kadar! Artık TensorFlow Lite modellerini yürütüyorsunuz.

Daha fazla bilgi edin