ML Community Day is November 9! Join us for updates from TensorFlow, JAX, and more Learn more

TensorFlow se probó con los siguientes sistemas de 64 bits y es compatible con ellos:

  • Python 3.6 a 3.9
  • Ubuntu 16.04 o versiones posteriores
  • Windows 7 o versiones posteriores (con C++ redistribuible)
  • macOS 10.12.6 (Sierra) o versiones posteriores (no tiene compatibilidad con GPU)
# Requires the latest pip
pip install --upgrade pip
# Current stable release for CPU and GPU pip install tensorflow
# Or try the preview build (unstable) pip install tf-nightly

Instala TensorFlow con el administrador de paquetes pip de Python.

Los paquetes oficiales están disponibles para Ubuntu, Windows y macOS.

Consulta la guía de GPU para ver las tarjetas habilitadas para CUDA®.

Las imágenes de Docker de TensorFlow ya están configuradas para ejecutar TensorFlow. Se ejecuta un contenedor de Docker en un entorno virtual y es la forma más fácil de configurar la compatibilidad con GPU.

 docker pull tensorflow/tensorflow:latest  # Download latest stable image
docker run -it -p 8888:8888 tensorflow/tensorflow:latest-jupyter # Start Jupyter server

No necesitas instalar nada. Puedes ejecutar los instructivos de TensorFlow directamente en el navegador con Colaboratory, un proyecto de investigación de Google que se creó para ayudar a difundir la investigación y educación en el campo del aprendizaje automático. Es un entorno de notebook de Jupyter que no requiere configuración y se ejecuta completamente en la nube. Leer la entrada de blog

Compila tu primera app de AA

Crea e implementa modelos de TensorFlow en la Web y en dispositivos móviles.
TensorFlow.js es una librería de JavaScript acelerada por WebGL para entrenar e implementar modelos de AA en un navegador, Node.js, móviles y mucho más.
TensorFlow Lite es una solución liviana para dispositivos móviles o incorporados.