Instalación

Instalación de tensorflow_hub

La biblioteca tensorflow_hub se puede instalar junto con TensorFlow 1 y TensorFlow 2. Recomendamos que los nuevos usuarios comiencen con TensorFlow 2 de inmediato y que los usuarios actuales se actualicen.

Usar con TensorFlow 2

Usa pip para instalar TensorFlow 2 como de costumbre. (Consulte allí para obtener instrucciones adicionales sobre la compatibilidad con GPU). Luego, instale una versión actual de tensorflow-hub al lado (debe ser 0.5.0 o más reciente).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

La API estilo TF1 de TensorFlow Hub funciona con el modo de compatibilidad v1 de TensorFlow 2.

Uso heredado con TensorFlow 1

TensorFlow 1.15 es la única versión de TensorFlow 1.x que aún es compatible con la biblioteca tensorflow_hub (a partir de la versión 0.11.0). TensorFlow 1.15 tiene un comportamiento predeterminado compatible con TF1, pero contiene muchas funciones de TF2 bajo el capó para permitir cierto uso de las API de estilo TF2 de TensorFlow Hub.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Uso de versiones preliminares

Los paquetes pip tf-nightly y tf-hub-nightly se crean automáticamente a partir del código fuente en github, sin pruebas de lanzamiento. Esto permite a los desarrolladores probar el código más reciente sin compilar desde el código fuente .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Próximos pasos