Montaż

Zadbaj o dobrą organizację dzięki kolekcji Zapisuj i kategoryzuj treści zgodnie ze swoimi preferencjami.

Instalowanie tensorflow_hub

Bibliotekę tensorflow_hub można zainstalować razem z TensorFlow 1 i TensorFlow 2. Zalecamy, aby nowi użytkownicy zaczęli od razu z TensorFlow 2, a obecni użytkownicy zaktualizowali go.

Używaj z TensorFlow 2

Użyj pip , aby zainstalować TensorFlow 2 jak zwykle. (Zobacz tam, aby uzyskać dodatkowe instrukcje dotyczące obsługi GPU.) Następnie zainstaluj obok niego aktualną wersję tensorflow-hub (musi być w wersji 0.5.0 lub nowszej).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

Interfejs API w stylu TF1 TensorFlow Hub współpracuje z trybem zgodności v1 TensorFlow 2.

Stosowanie starszego typu z TensorFlow 1

TensorFlow 1.15 to jedyna wersja TensorFlow 1.x nadal obsługiwana przez bibliotekę tensorflow_hub (od wydania 0.11.0). TensorFlow 1.15 domyślnie zachowuje się zgodnie z TF1, ale zawiera wiele funkcji TF2 pod maską, aby umożliwić pewne wykorzystanie interfejsów API w stylu TF2 TensorFlow Hub.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Korzystanie z wersji przedpremierowych

Pakiety pip tf-nightly i tf-hub-nightly są budowane automatycznie z kodu źródłowego na github, bez testowania wydania. Pozwala to programistom wypróbować najnowszy kod bez budowania ze źródeł .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Następne kroki