Instalar en pc

Construcciones estables

Instale la última versión de TensorFlow Probability:

pip install --upgrade tensorflow-probability

La probabilidad de TensorFlow depende de una versión estable reciente de TensorFlow (paquete pip tensorflow ). Consulta las notas de la versión de TFP para obtener detalles sobre las dependencias entre TensorFlow y TensorFlow Probability.

Para forzar una instalación específica de Python 3, reemplace pip con pip3 en los comandos anteriores. Para obtener ayuda de instalación adicional, orientación sobre la instalación de requisitos previos y (opcionalmente) configurar entornos virtuales, consulte la guía de instalación de TensorFlow .

Construcciones nocturnas

También hay compilaciones nocturnas de TensorFlow Probability en el paquete pip tfp-nightly , que dependen de tf-nightly y tf-nightly-gpu . Las compilaciones nocturnas incluyen características más nuevas, pero pueden ser menos estables que las versiones versionadas.

Instalar desde la fuente

También puede instalar desde la fuente. Esto requiere el sistema de compilación Bazel . Se recomienda encarecidamente que instales la compilación nocturna de TensorFlow ( tf-nightly ) antes de intentar compilar TensorFlow Probability desde la fuente.

  sudo apt-get install bazel git python-pip
  python -m pip install --upgrade --user tf-nightly
  git clone https://github.com/tensorflow/probability.git
  cd probability
  bazel build --copt=-O3 --copt=-march=native :pip_pkg
  PKGDIR=$(mktemp -d)
  ./bazel-bin/pip_pkg $PKGDIR
  python -m pip install --upgrade --user $PKGDIR/*.whl