Penginstalan

Tetap teratur dengan koleksi Simpan dan kategorikan konten berdasarkan preferensi Anda.

Memasang tensorflow_hub

Pustaka tensorflow_hub dapat dipasang bersama TensorFlow 1 dan TensorFlow 2. Kami menyarankan agar pengguna baru segera memulai dengan TensorFlow 2, dan pengguna saat ini memutakhirkannya.

Gunakan dengan TensorFlow 2

Gunakan pip untuk menginstal TensorFlow 2 seperti biasa. (Lihat di sana untuk petunjuk tambahan tentang dukungan GPU.) Kemudian instal versi terbaru dari tensorflow-hub di sebelahnya (harus 0.5.0 atau lebih baru).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

API TensorFlow Hub bergaya TF1 berfungsi dengan mode kompatibilitas v1 dari TensorFlow 2.

Penggunaan lama dengan TensorFlow 1

TensorFlow 1.15 adalah satu-satunya versi TensorFlow 1.x yang masih didukung oleh library tensorflow_hub (mulai rilis 0.11.0). TensorFlow 1.15 default ke perilaku yang kompatibel dengan TF1 tetapi berisi banyak fitur TF2 di bawah tenda untuk memungkinkan beberapa penggunaan API gaya TF2 TensorFlow Hub.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Penggunaan versi pra-rilis

Paket pip tf-nightly dan tf-hub-nightly dibangun secara otomatis dari kode sumber di github, tanpa pengujian rilis. Ini memungkinkan pengembang mencoba kode terbaru tanpa membangun dari sumber .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Langkah selanjutnya