Google I/O — это обертка! Наверстать упущенное в сеансах TensorFlow Просмотреть сеансы

Монтаж

Установка tensorflow_hub

tensorflow_hub библиотека может быть установлена вместе с TensorFlow 1 и TensorFlow 2. Мы рекомендуем новым пользователям начать с TensorFlow 2 сразу, а нынешние пользователи перейти на него.

Использование с TensorFlow 2

Используйте пип , чтобы установить TensorFlow 2 , как обычно. (См там дополнительные инструкции по поддержке GPU.) Затем установить текущую версию tensorflow-hub рядом с ним (должен быть 0.5.0 или более поздней версии).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

API-интерфейс TensorFlow Hub в стиле TF1 работает с режимом совместимости v1 TensorFlow 2.

Устаревшее использование с TensorFlow 1

TensorFlow 1,15 является единственной версией TensorFlow 1.x до сих пор поддерживается tensorflow_hub библиотекой (с версии 0.11.0). TensorFlow 1.15 по умолчанию использует TF1-совместимое поведение, но содержит множество скрытых функций TF2, позволяющих в некоторой степени использовать API-интерфейсы TensorFlow Hub в стиле TF2.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Использование предварительных версий

Пакеты пипа tf-nightly и tf-hub-nightly построены автоматически из исходного кода на GitHub, без тестирования выпуска. Это позволяет разработчикам попробовать последнюю версию кода без построения из исходных текстов .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Следующие шаги