Cette page a été traduite par l'API Cloud Translation.
Switch to English

Installation

Installation de tensorflow_hub

La bibliothèque tensorflow_hub peut être installée avec TensorFlow 1 et TensorFlow 2. Nous recommandons aux nouveaux utilisateurs de commencer immédiatement avec TensorFlow 2 et aux utilisateurs actuels de la mettre à niveau.

Utiliser avec TensorFlow 2

Utilisez pip pour installer TensorFlow 2 comme d'habitude. (Voir là pour des instructions supplémentaires sur la prise en charge du GPU.) Ensuite, installez une version actuelle de tensorflow-hub côté (doit être 0.5.0 ou plus récent).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

L'API de type TF1 de TensorFlow Hub fonctionne avec le mode de compatibilité v1 de TensorFlow 2.

Utilisation héritée avec TensorFlow 1

La bibliothèque tensorflow_hub nécessite TensorFlow version 1.7 ou supérieure.

Nous vous recommandons vivement de l'installer avec TensorFlow 1.15, qui utilise par défaut un comportement compatible TF1 mais contient de nombreuses fonctionnalités TF2 sous le capot pour permettre une certaine utilisation des API de type TF2 de TensorFlow Hub.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Utilisation de versions préliminaires

Les packages pip tf-nightly et tf-hub-nightly sont construits automatiquement à partir du code source sur github, sans test de version. Cela permet aux développeurs d'essayer le dernier code sans construire à partir des sources .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Prochaines étapes