Início rápido para dispositivos baseados em Linux com Python

Usar o TensorFlow Lite com Python é ótimo para dispositivos embarcados baseados em Linux, como dispositivos Raspberry Pi e Coral com Edge TPU , entre muitos outros.

Esta página mostra como você pode começar a executar modelos do TensorFlow Lite com Python em apenas alguns minutos. Tudo o que você precisa é de um modelo do TensorFlow convertido para o TensorFlow Lite . (Se você ainda não tiver um modelo convertido, poderá experimentar usando o modelo fornecido com o exemplo do link abaixo.)

Sobre o pacote de tempo de execução do TensorFlow Lite

Para começar a executar rapidamente os modelos do TensorFlow Lite com Python, você pode instalar apenas o interpretador do TensorFlow Lite, em vez de todos os pacotes do TensorFlow. Chamamos esse pacote simplificado do Python de tflite_runtime .

O pacote tflite_runtime é uma fração do tamanho do pacote tensorflow completo e inclui o código mínimo necessário para executar inferências com o TensorFlow Lite, principalmente a classe Interpreter Python. Este pequeno pacote é ideal quando tudo o que você quer fazer é executar modelos .tflite e evitar o desperdício de espaço em disco com a grande biblioteca TensorFlow.

Instale o TensorFlow Lite para Python

Você pode instalar no Linux com pip:

python3 -m pip install tflite-runtime

Plataformas compatíveis

As rodas do Python tflite-runtime são pré-construídas e fornecidas para estas plataformas:

  • Linux armv7l (por exemplo, Raspberry Pi 2, 3, 4 e Zero 2 executando Raspberry Pi OS de 32 bits)
  • Linux aarch64 (por exemplo, Raspberry Pi 3, 4 rodando Debian ARM64)
  • Linux x86_64

Se você deseja executar modelos do TensorFlow Lite em outras plataformas, deve usar o pacote completo do TensorFlow ou compilar o pacote tflite-runtime da fonte .

Se estiver usando o TensorFlow com o Coral Edge TPU, siga a documentação de configuração do Coral apropriada.

Execute uma inferência usando tflite_runtime

Em vez de importar o Interpreter do módulo tensorflow , agora você precisa importá-lo de tflite_runtime .

Por exemplo, depois de instalar o pacote acima, copie e execute o arquivo label_image.py . Ele (provavelmente) falhará porque você não tem a biblioteca tensorflow instalada. Para corrigi-lo, edite esta linha do arquivo:

import tensorflow as tf

Então, em vez disso, lê-se:

import tflite_runtime.interpreter as tflite

E então mude esta linha:

interpreter = tf.lite.Interpreter(model_path=args.model_file)

Assim lê-se:

interpreter = tflite.Interpreter(model_path=args.model_file)

Agora execute label_image.py novamente. É isso! Agora você está executando modelos do TensorFlow Lite.

Saber mais

,

Usar o TensorFlow Lite com Python é ótimo para dispositivos embarcados baseados em Linux, como dispositivos Raspberry Pi e Coral com Edge TPU , entre muitos outros.

Esta página mostra como você pode começar a executar modelos do TensorFlow Lite com Python em apenas alguns minutos. Tudo o que você precisa é de um modelo do TensorFlow convertido para o TensorFlow Lite . (Se você ainda não tiver um modelo convertido, poderá experimentar usando o modelo fornecido com o exemplo do link abaixo.)

Sobre o pacote de tempo de execução do TensorFlow Lite

Para começar a executar rapidamente os modelos do TensorFlow Lite com Python, você pode instalar apenas o interpretador do TensorFlow Lite, em vez de todos os pacotes do TensorFlow. Chamamos esse pacote simplificado do Python de tflite_runtime .

O pacote tflite_runtime é uma fração do tamanho do pacote tensorflow completo e inclui o código mínimo necessário para executar inferências com o TensorFlow Lite, principalmente a classe Interpreter Python. Este pequeno pacote é ideal quando tudo o que você quer fazer é executar modelos .tflite e evitar o desperdício de espaço em disco com a grande biblioteca TensorFlow.

Instale o TensorFlow Lite para Python

Você pode instalar no Linux com pip:

python3 -m pip install tflite-runtime

Plataformas compatíveis

As rodas do Python tflite-runtime são pré-construídas e fornecidas para estas plataformas:

  • Linux armv7l (por exemplo, Raspberry Pi 2, 3, 4 e Zero 2 executando Raspberry Pi OS de 32 bits)
  • Linux aarch64 (por exemplo, Raspberry Pi 3, 4 rodando Debian ARM64)
  • Linux x86_64

Se você deseja executar modelos do TensorFlow Lite em outras plataformas, deve usar o pacote completo do TensorFlow ou compilar o pacote tflite-runtime da fonte .

Se estiver usando o TensorFlow com o Coral Edge TPU, siga a documentação de configuração do Coral apropriada.

Execute uma inferência usando tflite_runtime

Em vez de importar o Interpreter do módulo tensorflow , agora você precisa importá-lo de tflite_runtime .

Por exemplo, depois de instalar o pacote acima, copie e execute o arquivo label_image.py . Ele (provavelmente) falhará porque você não tem a biblioteca tensorflow instalada. Para corrigi-lo, edite esta linha do arquivo:

import tensorflow as tf

Então, em vez disso, lê-se:

import tflite_runtime.interpreter as tflite

E então mude esta linha:

interpreter = tf.lite.Interpreter(model_path=args.model_file)

Assim lê-se:

interpreter = tflite.Interpreter(model_path=args.model_file)

Agora execute label_image.py novamente. É isso! Agora você está executando modelos do TensorFlow Lite.

Saber mais