Esta página foi traduzida pela API Cloud Translation.
Switch to English

Instalação

Instalando tensorflow_hub

A biblioteca tensorflow_hub pode ser instalada junto com o TensorFlow 1 e o TensorFlow 2. Recomendamos que os novos usuários comecem com o TensorFlow 2 imediatamente e que os usuários atuais façam upgrade para ele.

Use com TensorFlow 2

Use pip para instalar o TensorFlow 2 normalmente. (Veja lá para obter instruções extras sobre o suporte de GPU.) Em seguida, instale uma versão atual do tensorflow-hub próximo a ele (deve ser 0.5.0 ou mais recente).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

A API estilo TF1 do TensorFlow Hub funciona com o modo de compatibilidade v1 do TensorFlow 2.

Uso legado com TensorFlow 1

A biblioteca tensorflow_hub requer TensorFlow versão 1.7 ou superior.

É altamente recomendável instalá-lo com o TensorFlow 1.15, que tem como padrão o comportamento compatível com TF1, mas contém muitos recursos do TF2 subjacentes para permitir algum uso das APIs estilo TF2 do TensorFlow Hub.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Uso de versões de pré-lançamento

Os pacotes pip tf-nightly e tf-hub-nightly são construídos automaticamente a partir do código-fonte no github, sem teste de lançamento. Isso permite que os desenvolvedores experimentem o código mais recente sem compilar a partir do código-fonte .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Próximos passos