Questa pagina è stata tradotta dall'API Cloud Translation.
Switch to English

Installazione

Installazione di tensorflow_hub

La libreria tensorflow_hub può essere installata insieme a TensorFlow 1 e TensorFlow 2. Si consiglia ai nuovi utenti di iniziare subito con TensorFlow 2 e di aggiornarlo agli utenti attuali.

Utilizzare con TensorFlow 2

Usa pip per installare TensorFlow 2 come al solito. (Vedere qui per ulteriori istruzioni sul supporto GPU.) Quindi installare una versione corrente di tensorflow-hub accanto (deve essere 0.5.0 o più recente).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

L'API in stile TF1 di TensorFlow Hub funziona con la modalità di compatibilità v1 di TensorFlow 2.

Uso precedente con TensorFlow 1

La libreria tensorflow_hub richiede TensorFlow versione 1.7 o successiva.

Consigliamo vivamente di installarlo con TensorFlow 1.15, che per impostazione predefinita ha un comportamento compatibile con TF1 ma contiene molte funzionalità TF2 sotto il cofano per consentire un uso delle API in stile TF2 di TensorFlow Hub.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Uso di versioni preliminari

I pacchetti pip tf-nightly e tf-hub-nightly vengono creati automaticamente dal codice sorgente su GitHub, senza alcun test di rilascio. Ciò consente agli sviluppatori di provare il codice più recente senza compilare dal codice sorgente .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Prossimi passi