تركيب

تثبيت tensorflow_hub

و tensorflow_hub مكتبة يمكن تثبيت جنبا إلى جنب مع TensorFlow 1 و 2. TensorFlow من المستحسن أن المستخدمين الجدد مع بدء TensorFlow 2 على الفور، والمستخدمين الحاليين الترقية إلى ذلك.

استخدم مع TensorFlow 2

استخدام نقطة ل تثبيت TensorFlow 2 كالمعتاد. (انظر هناك للحصول على تعليمات إضافية حول دعم GPU.) ثم تثبيت الإصدار الحالي من tensorflow-hub بجانبه (يجب أن يكون 0.5.0 أو أحدث).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

تعمل واجهة برمجة تطبيقات TensorFlow Hub على غرار TF1 مع وضع التوافق v1 الخاص بـ TensorFlow 2.

الاستخدام القديم مع TensorFlow 1

TensorFlow 1.15 هو الإصدار الوحيد من TensorFlow 1.X لا يزال يدعمه tensorflow_hub مكتبة (كما الإفراج 0.11.0). يتم تعيين TensorFlow 1.15 افتراضيًا على السلوك المتوافق مع TF1 ولكنه يحتوي على العديد من ميزات TF2 الموجودة أسفل الغطاء للسماح ببعض استخدام واجهات برمجة التطبيقات TensorFlow Hub على غرار TF2.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

استخدام إصدارات ما قبل النشر

حزم نقطة tf-nightly و tf-hub-nightly يتم بناؤها تلقائيا من شفرة المصدر على جيثب، مع عدم وجود اختبار الإصدار. هذا يتيح للمطورين محاولة الخروج من آخر رمز من دون بناء من المصدر .

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

الخطوات التالية