Kurulum

Koleksiyonlar ile düzeninizi koruyun İçeriği tercihlerinize göre kaydedin ve kategorilere ayırın.

tensorflow_hub'ı yükleme

tensorflow_hub kitaplığı, TensorFlow 1 ve TensorFlow 2 ile birlikte kurulabilir. Yeni kullanıcıların hemen TensorFlow 2'ye başlamasını ve mevcut kullanıcıların buna yükseltme yapmasını öneririz.

TensorFlow 2 ile kullanın

TensorFlow 2'yi her zamanki gibi kurmak için pip kullanın. (GPU desteği hakkında ek talimatlar için oraya bakın.) Ardından, tensorflow-hub güncel bir sürümünü yükleyin (0.5.0 veya daha yeni olmalıdır).

$ pip install "tensorflow>=2.0.0"
$ pip install --upgrade tensorflow-hub

TensorFlow Hub'ın TF1 stili API'si, TensorFlow 2'nin v1 uyumluluk moduyla çalışır.

TensorFlow 1 ile eski kullanım

TensorFlow 1.15, hala tensorflow_hub kitaplığı tarafından desteklenen tek TensorFlow 1.x sürümüdür (0.11.0 sürümünden itibaren). TensorFlow 1.15, varsayılan olarak TF1 uyumlu davranışa geçer, ancak TensorFlow Hub'ın TF2 stili API'lerinin bir miktar kullanımına izin vermek için kaputun altında birçok TF2 özelliği içerir.

$ pip install "tensorflow>=1.15,<2.0"
$ pip install --upgrade tensorflow-hub

Yayın öncesi sürümlerin kullanımı

tf-nightly ve tf-hub-nightly pip paketleri, yayın testi yapılmadan github'daki kaynak koddan otomatik olarak oluşturulur. Bu, geliştiricilerin kaynaktan derleme yapmadan en son kodu denemelerini sağlar.

$ pip install tf-nightly
$ pip install --upgrade tf-hub-nightly

Sonraki adımlar